Security Release for issue4155

Publicat: 2014-09-30 10:00:00+00:00   |   Прочесть по-русски   |   Lire en français   |   Read in English   |   Auf Deutsch lesen   |   Beri v slovenščini   |   Leer en español   |  Més entrades sobre release security


A vulnerability in trytond has been found by duesenfranz, that might allow a malicious user to execute arbitrary commands on the server via the safe_eval function (see issue4155).


Any authenticated user can run arbitrary commands on the server with the permissions of the trytond user.


There is no workaround.


All users should upgrade trytond to the latest version of the used series.


Any security concerns should be reported on the bug-tracker at with the type security.