IRC logs of #tryton for Wednesday, 2018-02-21 #tryton log beginning Wed Feb 21 00:00:01 CET 2018
-!- csotelo(~csotelo@ has joined #tryton00:02
-!- cedk(~ced@gentoo/developer/cedk) has joined #tryton01:02
-!- csotelo(~csotelo@ has joined #tryton01:02
-!- thaneor( has joined #tryton01:02
-!- rmu( has joined #tryton03:02
-!- yangoon(~mathiasb@ has joined #tryton04:02
-!- rmu( has joined #tryton04:02
-!- hedererjs( has joined #tryton04:02
-!- hedererjs( has joined #tryton07:02
-!- _2cadz_( has joined #tryton07:02
-!- NeonKing-(~Neonking@ has joined #tryton08:02
-!- _2cadz( has joined #tryton08:02
-!- buxy( has joined #tryton09:02
-!- mrichez( has joined #tryton09:02
-!- xcodinas( has joined #tryton09:02
-!- cedk(~ced@gentoo/developer/cedk) has joined #tryton09:02
-!- nicoe( has joined #tryton09:02
-!- rpit( has joined #tryton09:02
-!- Artem(5d491808@gateway/web/freenode/ip. has joined #tryton09:02
ArtemHello. Just wondering - is there any way to delete an account from the list of accounts in Finance-Configuration-Accounts in the SAO client? There are no account moves neither parties linked to this account. Thanks09:02
cedkArtem: so probably otherwise you can just deactivate it09:02
Artemcedk: thanks, will use deactivate option for the non-required account.10:02
rmucedk: re. issue7152, should I create a second issue? there are 2 situations with similar outcome10:02
rmucedk: first is: split _outgoing_ move on shipment, that removes the link to invoice lines of draft invoice10:02
rmucedk: second is: split _inventory_ move on shipment, that eventually also removes the link to invoice lines, but the mechanism is different10:02
cedkrmu: no I already explained what is the problem10:02
cedkrmu: it is the same problem10:02
rmucedk: ok nevermind.10:02
-!- udono( has joined #tryton11:02
-!- udono( has joined #tryton11:02
rmucedk: if I understand correctly, the move-copies in stock_split and stock_lot and potentially other modules should be wrapped in something like "with Transaction().set_context(somekeyword=True)" and move.copy in account_invoice_stock will use check Transaction().context.get('somekeyword') to prevent the setdefault('invoice_lines', None)11:02
cedkrmu: yes11:02
cedkand even, I'm wondering if we should not have a specific method for such copy call11:02
rmusomething like "create_sibling"?11:02
cedkrmu: yes but a better name11:02
cedkindeed split would have been great but it is already taken by stock_split12:02
rmuis it not possible to rename method in stock_split?12:02
cedkrmu: why?12:02
rmubut name like split or divide would imply that sum(quantity) before split is sum(quantity) after split12:02
rmucedk: because it would be better name? *g*12:02
-!- mariomop(~quassel@ has joined #tryton12:02
cedkrmu: the usage that must be fixed, implies this equality12:02
-!- hedererjs( has joined #tryton12:02
-!- rpit( has joined #tryton13:02
-!- meigallodixital( has joined #tryton13:02
-!- giesen( has joined #tryton13:02
-!- thaneor1( has joined #tryton13:02
-!- Timitos( has joined #tryton17:02
-!- Telesight( has joined #tryton18:02
-!- rpit( has joined #tryton19:02
-!- catonano(~user@ has joined #tryton21:02
-!- _2cadz( has joined #tryton21:02
-!- semarie_(~semarie@unaffiliated/semarie) has joined #tryton22:02
-!- mariomop(~quassel@ has joined #tryton22:02
-!- NeonKing(~Neonking@ has joined #tryton22:02

Generated by 2.16.0 by Marius Gedminas - find it at!